Multi-site Wordpress require authentication on one site only

  • John Spaid
    # 6 months, 1 week ago

    I have a Premium plugin for my multisite WP instance. How can I require login for an entire sub-site but not all the other sites?

    Kalpesh
    Keymaster
    # 6 months, 1 week ago

    @John, as I understand login restriction is working only on one subsite and you want it to work on all subsites right? Please confirm.

    This is supported with the Multisite version of our premium plugin.

    Can you confirm if you have Multisite version of our plugin? If you are not sure, please send us a version of the plugin you are using.

    John Spaid
    # 6 months ago

    I have the multisite plugin and it is working for login to the Dashboard for all sites in the network. That is good. I have one new site that I don’t want anyone to get to unless they login, Dashboard or website itself. Basically, a totally non-public site on the multisite network. I see this is a supported feature but I can’t figure out how to set it up.

    Kalpesh
    Keymaster
    # 6 months ago

    Hi John,

    To achieve this, you can follow the steps below.
    1) Go to “Role Mapping” tab
    2) Select subsite from the dropdown which you want to keep non-public
    3) Check option “Do not auto create users if roles are not mapped here.”

    Also, you will need to make sure you do not have existing users in non-public subsite to which you do not want to give access.

    Let me know if you have any questions.

    John Spaid
    # 6 months ago

    That only stops the creation of users. I don’t want anyone to get to the site. There’s an option on the SSO Login Settings tab:

    Redirect to IdP if user not logged in. [What does this mean?]
    Select this option if you want to restrict your site to only logged in users. Selecting this option will redirect the users to your IdP if logged in session is not found.

    That’s what I need, but only on one site.

    Kalpesh
    Keymaster
    # 5 months, 4 weeks ago

    Hi John,

    I will mark it resolved as you have confirmed it’s working on our email thread.

    Thanks.

Viewing 6 posts - 1 through 6 (of 6 total)

Reply