WordPress OTP is not working on Multi-Step or Multi-Page WPForms

  • khurramsikandar
    Participant
    # 6 months, 3 weeks ago

    Hi,

    Your WordPress OTP Verification is not working on Multi-Step WPForms.

    Its actually showing Send OTP button on multipage form but problem is users can bypass Send OTP and move on to next page without verifying OTP.

    Are you working or adding this feature in your plugin in upcoming releases or is there any workaround or hook that we can add in code so OTP won’t bypass by the users and multi-page form won’t move to the next page until users verify OTP.

    Thanks

    akankshakesarkar
    Participant
    # 6 months, 2 weeks ago

    Hello,

    Thanks for contacting us.

    Could you please share the URL to your WPForms multistep page? We would like to assess the compatibility of our plugin with multistep WPForms.
    Additionally, please confirm if you are using any premium addon of the WPForms so that I will try to create a replica of the same on our end and test it.

    For quicker responses, feel free to reach out to us at mfasupportt@xecurify.com

    Thank you!

    khurramsikandar
    Participant
    # 6 months, 2 weeks ago

    Hi,

    This is the form link:

    Get Pre-Approved – New

    You can see at the last step or page of the form we have integrated your OTP. So basically OTP is working now but only issue we are facing that Verify OTP button is showing from the start and this has to be hidden and will only be active or visible once people click on Get OTP button and that’s the normal behavior of your plugin.

    So if you could tell us or fix for us how can we hide Verify OTP button at start and only visible once people click on Get OTP button then it visible with text field to enter OTP.

    Thanks

    akankshakesarkar
    Participant
    # 6 months, 1 week ago

    Hello,

    Thank you for your reply.

    In the default functionality of the plugin, the Verify OTP button is hidden and only visible after the OTP is sent.
    It seems this is a site-specific issue and there is a CSS conflict with the theme/plugins you are using.

    Please let me know how you would like to connect so that we can resolve the conflict.
    You can reach out to us on our support by clicking on the Need Help icon on the bottom right of the plugin so that we can help you with your query.

    Thanks

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.